Anar al contingut

Request for Comments

De L'Enciclopèdia, la wikipedia en valencià

Els 'Request for Comments', més coneguts per les seues sigles RFC, són una série de publicacions del grup de treball d'ingenieria d'internet que descriuen diversos aspectes del funcionament d'Internet i unes atres rets de computadores, com protocols, procediments, etc. i comentaris i idees sobre estos.[1][2] Cada 'RFC' constituïx un monogràfic o memoràndum que ingeniers o experts en la matèria han fet aplegar al IETF, el consorci de colaboració tècnica més important en Internet, per a que este siga valorat pel restant de la comunitat. De fet, la traducció lliteral de RFC a l'espanyol és "Petició de comentaris".[2]

Estes publicacions es remonten a 1969, quan Steve Crocker va inventar un sistema eficaç de fer aplegar les propostes tècniques al restant de grups de treball que experimentaven en ARPANET, la precursora d'Internet.[3]

Els protocols més importants d'Internet estan definits per RFC, com el protocol IP detallat en el RFC 791, el FTP en el RFC 959, o l'HTTP —escrit per Tim Berners-Lee et al.— en el RFC 2616 (entre uns atres).

Característiques

Cada RFC té un títul i un número assignat, que no pot repetir-se ni eliminar-se encara que el document es quede obsolet.


Existixen vàries categories, podent ser informatius (quan es tracta simplement de valorar per eixemple l'implantació d'un protocol), propostes d'estàndarts nous, o històrics (quan queden obsolets per versions més modernes del protocol que descriuen).

Les RFC es redacten en anglés segons una estructura específica i en format de text ASCII.

Ans que un document tinga la consideració de RFC, deu seguir un procés molt estricte per a assegurar la seua calitat i coherència. Quan ho conseguix, pràcticament ya és un protocol formal al que provablement s'interpondran poques objeccions, per lo que el sentit del seu nom com a petició de comentaris ha quedat pràcticament obsolet, ya que les crítiques i sugerències es produïxen en les fases anteriors. De tots modos, el nom de RFC es manté per raons històriques.

Estat

l'Internet Architecture Board (IAB), un comité del IETF, manté una llista de RFCs que descriuen la família de protocols. Classifica el seu estat de dos formes independents:[4][5]

Passos d'una especificació per a convertir-se en estàndart (RFC 2026)
  • La primera establix el grau de madurea de l'especificació i la proposta pot ser considerada respecte a ella com:
    • Estàndart (en anglés standard).- És una norma
    • Estàndart borrador (en anglés draft standard).- El IAB està considerant activament este protocol com un possible protocol estàndar. Existix una possibilitat que canvie, eixos canvis seran fets en un borrador del protocol abans de lliberar-los com a estàndar.
    • Estàndart propost (en anglés proposed standard).- És una proposta que deu considerar el IAB per a la seua estandardisació en el futur. És provable la revisió del protocol
    • Experimental (en anglés experimental).- És una especificació experimental que no deuria implementar-se a no ser que estiga participant en l'experiment i ha coordinat el seu us del protocol en el desenrollador del protocol.
    • Informatiu (en anglés informational).- Els protocol desenrollats per atres organisacions o que en general que estan fòra de l'alcanç de el IAB deuen publicar-se com RFCs per conveniència de la comunitat d'Internet com a protocols informatius. Este tipo de protocols poden en alguns casos també estar recomanats per al seu us en Internet per IAB.
    • Històric (en anglés historic).- És poc provable que passen a ser estàndars en Internet perque els han reemplaçat els desenrolladors més vesprada o per falta d'interés
  • La segona forma de classificació definix el grau de compliment necessari de la norma dins d'Internet
    • Requerit (en anglés required).- És de compliment obligat. Per eixemple, el RFC del protocol IP
    • Recomanat (en anglés reconmmended).- Aquelles que, si no són complides, no impedixen la conexió a Internet, pero afecten de manera important a la prestació i accés als servicis. La noció general és que si es va a fer alguna cosa com açò deuria fer exactament açò. Per eixemple, el RFC de TCP
    • Electiu (en anglés elective).- Aquelles que, encara que no són enteses com d'aplicació general, sí són necessàries per a un cert servici concret. Per eixemple, la de SMTP per a accedir al correu electrònic
    • Us llimitat (en anglés limited use).- Està per a usar en circumstàncies llimitades. Açò pot ser pel seu estat experimental, naturalea específica, funcionalitat llimitada o estat històric.
    • No recomanat (en anglés not recommeded).- Aquelles que no es recomanen per a us general. Açò pot ser per la seua funcionalitat llimitada, naturalea específica o estat experimental o històric.

Referències

  1. ↑ Tens que especificar títul = i url = al usar {{cita web}}.IETF. . www.ietf.org. Consultat el 9 de març de 2014. «Memos in the Requests for Comments (RFC) document séries contain technical and organizational notes about the Internet. They cover many aspects of computer networking, including protocols, procedures, programs, and concepts, as well as meeting notes, opinions, and sometimes humor» Trad: «Els monogràfics en la série de documents Requests for Comments (RFC) conté notes tècniques i organisatives sobre Internet. Cobrixen múltiples aspectes sobre les rets d'ordenadors, incloent protocols, procediments, programes, i conceptes, aixina com notes de reunions, opinions, i en ocasions humor»
  2. ↑ 2,0 2,1 «¿Quí controla Internet? Gobernanza, polítiques i desafius per al futur de la ret de rets».AVATARES de la comunicació i la cultura.(2)Consultat el 14 de març de 2014.
  3. ↑ «30 Years of RFCs» (en en) (txt). RFC 2555. Archivat des d'el original, el 4 d'agost de 2000. Consultat el 14 de març de 2014. «Publication of RFC 1 - Steve Crocker: RFC 1, "Host Software", issued thirty years ago on April 7, 1969 outlined some thoughts and initial experiments. It was a modest and entirely forgettable memo, but it has significance because it was part of a broad initiative whose impact is still with us today. At the clave RFC 1 was written, the ARPANET was still under design.» Trad: «Publicació de la RFC 1 - Steve Crocker: RFC 1, "Host Software", publicat fa 30 anys el 7 d'abril de 1969 desenrollava alguns pensaments i experiments inicials. Era un modest i res memorable memoràndum, pero posseïx una rellevància pròpia degut a que va ser part d'una iniciativa més gran que encara hui té impacte. Quan la RFC 1 va ser escrita, la ARPANET encara estava dissenyant-se.»
  4. ↑ Internet. La Ret En Mayusculas. Una introducció a l'estructura i servicis de la Ret Global. Diego R. López. Editorial MAD, S.L. Maig de 1997
  5. ↑ Request For Comments (- RFC -Petició de Comentaris) . CINVESTAV-Tamaulipas. LABORATORIO DE TECNOLOGIAS INFORMACION