Sistema de noms de domini
El sistema de noms de domini (Domain Name System o DNS, per les seues sigles en anglés)[1] és un sistema de nomenclatura jeràrquic descentralisat per a dispositius conectats a rets IP com Internet o una ret privada. Este sistema associa informació variada en nomenes de domini assignats a cada u dels participants. La seua funció més important és la resolució de noms, «traduir» noms inteligibles per a les persones en identificadors binaris associats en els equips conectats a la ret en el propòsit de poder localisar i direccionar estos equips mundialment.[2]
El servidor DNS utilisa una base de senyes distribuïda i jeràrquica que almagasena informació associada a nomenes de domini en rets com Internet. Encara que com a base de senyes el DNS és capaç d'associar diferents tipos d'informació a cada nom, els usos més comuns són l'assignació de noms de domini a direccionar IP i la localisació dels servidors de correu electrònic de cada domini.
L'assignació de noms a direccions IP és certament la funció més coneguda dels protocols DNS. Per eixemple, si la direcció IP del lloc Google és 216.58.210.163, la majoria de la gent aplega a este equip especificant www. google. com i no la direcció IP. Ademés de ser més fàcil de recordar, el nom és més fiable.[3] La direcció numèrica podria canviar per moltes raons, sense que tinga que canviar el nom del sitie web. Inclús, en el cas de que una pàgina web utilise una ret de distribució de continguts (Content delivery network o CDN, per les seues sigles en anglés) per mig del DNS l'usuari rebrà la direcció IP del servidor més propenc segons la seua localisació geogràfica (cada CDN a la seua volta té els seus propis servidors DNS).
Història
Principalment, el DNS va nàixer de la necessitat de recordar fàcilment els noms de tots els servidors conectats a Internet. En un inici, SRI (ara SRI International) estajava un archiu cridat HOSTS que contenia tots els noms de domini coneguts.[4][5]
El creiximent explosiu de la ret va causar que el sistema de noms centralisat en l'archiu hosts no resultara pràctic i en novembre de 1983 Jon Postel publica el planejament en el RFC 881 i després junt a Paul Mockapetris publiquen els RFC 882 i RFC 883 eixe mateix any. En octubre de 1984 i despuix de llargues discussions emeten el RFC 920,[6] definint lo que hui en dia ha evolucionat cap al DNS modern (estos RFC 882 i 883 varen ser reemplaçats en 1987 en els RFC 1034 i RFC 1035).[7]
De no existir els servidors DNS els usuaris tindrien que escriure la direcció IP del sitie web en lloc d'escriure l'URL d'este lo que generaria confusions i la navegació en internet es tornaria molt complicada per als usuaris.
En esta etapa, la millor forma de proveir «continuïtat» era tindre múltiples servidors contestant múltiples consultes. Un servidor era el mestre i els demés eren esclaus. Cada u dels esclaus devia revisar en el mestre periòdicament que les senyes no hagueren canviat.
Uns 10 anys despuix, es varen fer alguns ajusts majors al protocol DNS. Açò era una forma més dinàmica de mantindre els servidors al dia, utilisant NOTIFY (en espanyol notificar) i les transferències incrementals de zona (IXFR).[8]
NOTIFY va ser un canvi clau. En lloc d'esperar a que un esclau revisara, el mestre podia manar mensages NOTIFY als esclaus, instant-els a adquirir les noves senyes. Per la seua banda, IXFR va significar un canvi en la forma en que les senyes es comunicaven. Si canviava solament un d'entre centenars de registres, l'especificació original enviaria centenars de mensages. IXFR va canviar el sistema, permetent que solament s'enviaren els registres que varen canviar.[8]
La següent evolució de DNS va vindre quan es varen definir canvis dinàmics en RFC 2136. Açò va permetre que els administradors dels servidors pogueren fer canvis en els registres de millor forma. Més tart, en el RFC 2671 es varen definir mecanismes d'extensió de DNS (EDNS) que va modernisar encara més el sistema.[8]
L'interés per expandir els possibles noms dels dominis per a incloure caràcters d'atres idiomes es va reflectir en els noms de domini internacionalizados com varen ser definits en els RFC 5890 i RFC 5891 en 2010.
Components
Per a l'operació pràctica del sistema DNS s'utilisen tres components principals:
- Clients fase 1
- Un programa client DNS que s'eixecuta en la computadora de l'usuari i que genera peticions DNS de resolució de noms a un servidor DNS (Per eixemple: ¿Quina direcció IP correspon a nom. domini?)
- Servidors DNS
- Que contesten les peticions dels clients. Els servidors recursivos tenen la capacitat de reenviar la petició a un atre servidor si no disponen de la direcció solicitada.
- Zones d'autoritat
- És una part de l'espai de nom de dominis sobre la que és responsable un servidor DNS, que pot tindre autoritat sobre vàries zones. (Per eixemple: subdomini. Wikipedia. ORG, subdomini. COM, etc.)
Vore també
Atacs
Referències
- ↑ «archive. org/web/20080412050703/https://technet. microsoft. com/és-és/network/bb629410. aspx El Sistema de noms de domini» (en castellà) (html). Microsoft TechNet. Archivat des d'el microsoft. com/és-és/network/bb629410. aspx original, el 12 d'abril de 2008. Consultat el 16 de juliol de 2018. «Sistema de noms de domini (DNS) és una base de senyes distribuïda i jeràrquica que conté assignació de noms de domini de DNS a diferents tipos de senyes, com les direccions de protocol d'Internet (IP). El sistema DNS li permet usar noms senzills com www. microsoft. com, per a localisar equips de forma fàcil i atres recursos en rets basades en TCP/IP. DNS és un estàndart del Grup de treball d'ingenieria d'Internet (IETF).»
- ↑ «archive. org/web/20180716160714/https://progresser-en-informatique. com/formation/internet/comment-fonctionne-internet/ Comment fonctionne Internet?» (en fr) (html). progresser en informatique. Archivat des d'el com/formation/internet/comment-fonctionne-internet/ original, el 16 de juliol de 2018. Consultat el 16 de juliol de 2018. «Afin que chaque serveur puisse être identifié et atteint, ils possèdent tous unix adresse IP unique, comme votre lieu de domicile ou votre numéro de téléphone. Comme unix adresse IP est difficile à retenir (parell ex.: 216.27.69.178), nous leur donnons aussi un nom, comme google. com, facebook. com, etc. Dans li jargon, ce nom s’appelle un nom de domaine ou unix adresse URL. (...) Votre ordinateur envoie unix requête à votre fournisseur d’accès à Internet (Swissco, Free, etc.) et ce dernier va router (transmettre) votre demande à un serveur DNS (Domain Name Server) qui à són tour va faire correspondre li nom de domaine que vous avez vaig demandar à són adresse IP unique afin de pouvoir rediriger votre demande initiale vers li serveur Google adéquat dont l’adresse IP correspond au nom de domaine google. com»
- ↑ «archive. org/web/20151208023322/http://s2. postimg. org/ixmtj8io9/captura. png Consulta DNS des de CMD». Archivat des d'el postimg. org/ixmtj8io9/captura. png original, el 8 de decembre de 2015. Consultat el 26 de novembre de 2015.
- ↑ «livinginternet. com/i/iw_dns_history. htm Domain Name System (DNS) History» (en anglés). Consultat el 28 de febrer de 2016.
- ↑ «archive. org/web/20200219003525/https://www. consultorweb. pe/que-és-un-domini/ Que és un domini (DNS) History» (en anglés). Archivat des d'el consultorweb. pe/que-és-un-domini/ original, el 19 de febrer de 2020. Consultat el 28 de febrer de 2016.
- ↑ «archive. org/web/20180716153218/https://docs. microsoft. com/en-us/previous-versions/windows/it-pro/windows-server-2003/cc772774(v=ws.10) How DNS Works» (en en) (html). Microsoft Technet. Archivat des d'el microsoft. com/en-us/previous-versions/windows/it-pro/windows-server-2003/cc772774(v=ws.10) original, el 16 de juliol de 2018. Consultat el 16 de juliol de 2018. «The Domain Name System introduced in 1984 became this new system. With DNS, the host names residix in a database that ca be distributed among multiple servers, decreasing the lloeu on any one server and providing the ability to administer this naming system on a per-partition basis. DNS supports hierarchical names and allows registration of various data types in addition to host name to IP address mapping used in HOSTS files. Because the DNS database is distributed, its potential size is unlimited and performance is not degraded when more servers llaure added.»
- ↑ «cybertelecom. org/dns/history. htm History of DNS» (en anglés). CyberTelecom. Consultat el 28 de febrer de 2016.
- ↑ 8,0 8,1 8,2 «neustar. biz/blog/history-evolution-dns The History & Evolution of DNS – Starting from the Beginning» (en anglés). Consultat el 28 de febrer de 2016.
- Este artícul conté una traducció derivada de «Sistema de nombres de dominio» de Wikipedia en castellà publicada baix la Llicència de documentació lliure de GNU i la Llicència Creative Commons Reconeiximent-CompartirIgual 4.0 Internacional.