Anar al contingut

Comparació d'implementacions TLS

De L'Enciclopèdia, la wikipedia en valencià

Descripció general

Implementació Desenrollat per !

Còdic Obert

Llicència de Software Propietari(s) dels drets d'autor Escrit en Última versió estable, data de publicació Orige
GnuTLS Proyecte GnuTLS
Sí GNU LGPLv2.1+ Fundació de Software lliure C Estable - 3.5.18/16 de febrer de 2018; fa 4 mesos.[1] Pròxim estable: 3.6.2/16 de febrer de 2018; fa 4 mesos.[1] UE (Grècia i Suècia)
OpenSSL Proyecte OpenSSL
Sí Llicència doble OpenSSL-SSLeay Eric Young, Tim Hudson, Sun, Proyecte OpenSSL, i uns atres més C, Llenguage ensamblador 1.1.0h (27 de març de 2018; fa 3 mesos).[2] 1.0.2o (27 de març de 2018; fa 3 mesos).[2] Austràlia/UE
wolfSSL (prèviament CyaSSL) wolfSSL[3]
Sí GNU GPLv2+ i llicència comercial wolfSSL Inc.[4] C 3.15.3 (22 de juny de 2018; fa 15 dies).[5] US
Implementació Desenrollat per !

Còdic Obert

Llicència de Software Propietari(s) dels drets d'autor Escrit en Última versió estable, data de publicació Orige

Soporte de protocol

Existixen vàries versions del protocol TLS. SSL 2.0 és una versió obsoleta[6] del protocol en debilitats significatives. SSL 3.0 (1996) i TLS 1.0 (1999) li succeïxen en dos desventages en farcidura-CBC, les quals varen ser explicades en el 2001 per Serge Vaudenay.[7] TLS 1.1 (2006) solament va corregir un dels problemes en alternar aleatoriamente els vectores d'inicialisació (IV) per als blocs de sifrat CBC, mentres que l'us més problemàtic del sifrat mac-pad, no del sifrat pad-mac (el qual és més segur), va ser abordat en RFC7366.[8] Una solució alternativa per a SSL 3.0 i TLS 1.0, aproximadament equivalent als IVs aleatoris del TLS 1.1, va ser adoptada obertament per vàries implementacions a finals del 2011,[9] aixina que des d'una perspectiva de seguritat, totes les versions existents de TLS 1.0, 1.1 i 1.2 proveïxen una força equivalent en el protocol base que, fins a a lo manco el 2030, resulten més apropiades per a la seguritat de 128 bits d'acort al NIST SP800-57. En el 2014 es va descobrir la vulnerabilitat POODLE de SSL 3.0, la qual pren ventaja de la vulnerabilitats conegudes en CBC i d'una negociació de respal insegura usada en els navegadors web.[10]

TLS 1.2 (2008) és la versió més recentment publicada del protocol base, la qual introduïx una forma d'identificar els hashes usats per a firmes digitals. Mentres permet l'us de funcions hash més fortes per a les firmes digitals en el futur (rsa,sha256/sha384/sha512), per damunt de la seua alternativa més conservadora, SSL 3.0 (rsa,sha1+md5), el canvi de protocol TLS 1.2 inadvertida i substancialment debilita les firmes digitals per defecte i ademés proveïx (rsa,sha1) i inclús (rsa,md5).[11]

La capa de seguritat de transport de datagrama (DTLS o TLS de datagrama) 1.0 és una modificació del TLS 1.1 per a una capa de transport orientada a paquets, a on la pèrdua i reordenació de paquets deuen ser tolerades. La revisió de DTLS 1.2 basada en TLS 1.2 va ser publicada en giner del 2012[12]


cal notar que hi ha vulnerabilitats conegudes en SSL 2.0 i SSL 3.0. En l'excepció dels predibles IVs (per als quals existix una solució alternativa), totes les vulnerabilitats conegudes en l'actualitat afecten a totes les versions de TLS 1.0/1.1/1.2 per igual.[13]

Implementació SSL 2.0 (insegur)[14] SSL 3.0 (insegur)[15] TLS 1.0[16] TLS 1.1[17] TLS 1.2 TLS 1.3
(Borrador)[18][19]
DTLS 1.0[20] DTLS 1.2[12]
GnuTLS
No(a)
Inhabilitat per defecte[21]
Sí
Sí
Sí
Sí[22]
Sí
Sí
OpenSSL
No Habilitat per defecte
Sí
Sí[23]
Sí[23]
Sí
Sí
Sí[24]
wolfSSL
No
Desahabilitado per defecte[25]
Sí
Sí
Sí
Sí[26]
Sí
Sí
Implementació SSL 2.0 (insegur)[14] SSL 3.0 (insegur)[15] TLS 1.0[16] TLS 1.1[17] TLS 1.2 TLS 1.3
(Borrador)[18][19]
DTLS 1.0[20] DTLS 1.2[12]

(a) El client SSL 2.0 Hello està soportat aun cuando SSL 2.0 no estiga respalat o estiga inhabilitat per compatibilitat atrassades.

Vore també

Referències

  1. ↑ 1,0 1,1 «GnuTLS». Consultat el 3 de maig de 2016.
  2. ↑ 2,0 2,1 «OpenSSL: Newslog». Consultat el 3 de maig de 2016.
  3. ↑ «wolfSSL product description». Consultat el 3 de maig de 2016.
  4. ↑ «wolfSSL Embedded SSL/TLS». Consultat el 3 de maig de 2016.
  5. ↑ «wolfSSL ChangeLog». Consultat el 3 de maig de 2016.
  6. ↑ RFC6176: Prohibiting Secure Sockets Layer (SSL) Version 2.0
  7. ↑ «"CBC-Padding: Security Flaws in SSL, IPsec, WTLS,...", Serge Vaudenay, 2001».
  8. ↑ RFC7366: Encrypt-then-MAC for Transport Layer Security (TLS) and Datagram Transport Layer Security
  9. ↑ «Rizzo/Duong BEAST Countermeasures». Archivat des d'el original, el 23 de juny de 2018. Consultat el 7 de juliol de 2018.
  10. ↑ «This POODLE Bites: Exploiting The SSL 3.0 Fallback». Archivat des d'el original, el 14 d'octubre de 2014. Consultat el 15 d'octubre de 2014.
  11. ↑ TLSv1.2's Major Differences from TLSv1.1
  12. ↑ 12,0 12,1 12,2 RFC 6347
  13. ↑ Tens que especificar títul = i url = al usar {{cita web}}..
  14. ↑ 14,0 14,1 «draft-hickman-netscape-ssl-00».
  15. ↑ 15,0 15,1 RFC 6101
  16. ↑ 16,0 16,1 RFC 2246
  17. ↑ 17,0 17,1 RFC 4346
  18. ↑ 18,0 18,1 draft-ietf-tls-tls13-11 - The Transport Layer Security (TLS) Protocol Version 1.3
  19. ↑ 19,0 19,1 «tlswg/tls13-spec branches».
  20. ↑ 20,0 20,1 RFC 4347
  21. ↑ «[gnutls-devel GnuTLS 3.4.0 released]». Consultat el 16 d'abril de 2015.
  22. ↑ «Released GnuTLS 3.6.4 of the next branch with support for the final version of TLS1.3 [24 Sep 2018]». Consultat el 5 de juliol de 2019.
  23. ↑ 23,0 23,1 «Major changes between OpenSSL 1.0.0h and OpenSSL 1.0.1 [14 Mar 2012]» (14 de març de 2012). Archivat des d'el original, el 5 de decembre de 2014. Consultat el 20 de giner de 2015.
  24. ↑ «Major changes between OpenSSL 1.0.1l and OpenSSL 1.0.2 [22 Jan 2015]». Archivat des d'el original, el 4 de setembre de 2014. Consultat el 22 de giner de 2015.
  25. ↑ «[wolfssl wolfSSL 3.6.6 Released]». Consultat el 24 d'agost de 2015.
  26. ↑ «[wolfssl wolfSSL TLS 1.3 support updated to draft 23]». Consultat el 12 de març de 2018.


Referències