Anar al contingut

CalDAV

De L'Enciclopèdia, la wikipedia en valencià

Calendaring Extensions to WebDAV, o CalDAV, és un estàndart d'Internet que permet a un client accedir a informació de planificació en un servidor remot. Estén WebDAV (protocol basat en HTTP per a la manipulació de senyes) i utilisa iCalendar com a format per a les senyes. El protocol d'accés està definit per el RFC 4791. Permet que varis clients accedixquen a la mateixa informació, facilitant la cooperació. Moltes aplicacions, tant clients com a servidors, són compatibles en este protocol. Extensions de CalDAV per a planificar de forma automatizado també estan estandardisades, com RFC 6638.

Eixemple

L'eixemple està basat en el RFC 4791:

Solicitut:

REPORT /bernard/work/ HTTP/1.1
Host: calç.example.com
Depth: 1
Content-Type: application/xml; charset="utf-8"
Content-Length: xxxx

<?xml versió="1.0" encoding="utf-8" ?>
<C:free-busy-query xmlns:C="urn:ietf:params:xml:ns:caldav">
<C:clave-range start="20060104T140000Z" end="20060105T220000Z"/>
</C:free-busy-query>

Resposta:

HTTP/1.1 200 OK
Dona't: Sat, 11 Nov 2006 09:32:12 GMT
Content-Type: text/calendar
Content-Length: xxxx

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Example Corp.//CalDAV Server//EN
BEGIN:VFREEBUSY
DTSTAMP:20050125T090000Z
DTSTART:20060104T140000Z
DTEND:20060105T220000Z
FREEBUSY;FBTYPE=BUSY-TENTATIVE:20060104T150000Z/PT1H
FREEBUSY:20060104T190000Z/PT1H
END:VFREEBUSY
END:VCALENDAR

Implementacions

Clients

  • Agendav, un client web CalDAV de còdic obert.
  • Apple Calendar (anteriorment iCal)—El 7 d'agost de 2006, Apple va anunciar que Mac OS X 10.5 "Leopard" inclouria iCal 3.0, una aplicació compatible en els estàndarts CalDAV.[1] Mac OS X Server 10.5 inclou iCal Server, el qual implementa el protocol CalDAV.[2] iCal Server ha segut lliberat baix una llicència de còdic obert com el Servidor de Calendari de Darwin.[3] El 17 de març de 2009, Apple va anunciar que CalDAV seria inclós en l'iPhone 3.0 SDK.
  • Atmail, una implementació tant de client com de servidor, en soport per a una àmplia gama de clients d'escritori i dispositius mòvils.
  • Bynari WebDAV Collaborator, un plug-in per a sincronisar CalDAV i CardDAV en Outlook en la majoria de servidors DAV.
  • CalendarSync per a Android[4]
  • CalDAV-Sync per a Android[5]
  • DAVdroid per a Android[6]
  • Califòrnia, una aplicació gratuïta i de còdic obert per a GNOME 3.

Servidor

La llista del servidor CalDAV inclou::[11]

Vore també

Referències

  1. ↑ iCal at Apple Mac OS 10.5.
  2. ↑ iCal Server, Apple Mac OS 10.5.
  3. ↑ Calendar Server [1] archivat en Wayback Machine., Darwin.
  4. ↑ CalendarSync
  5. ↑ CalDAV-Sync
  6. ↑ «DAVdroid». davdroid.bitfire.at. Archivat des d'el original, el 11 de setembre de 2017. Consultat el 16 de novembre de 2015.
  7. ↑ TaskSync
  8. ↑ CalDavZAP
  9. ↑ EVO Collaborator for Outlook
  10. ↑ 10,0 10,1 Horde Groupware
  11. ↑ «CalDAV Servers (English)». Archivat des d'el original, el 24 d'octubre de 2008. Consultat el 7 de giner de 2014.
  12. ↑ «Baikal». Archivat des d'el original, el 14 de novembre de 2015. Consultat el 17 de novembre de 2015.
  13. ↑ «Bynari Collaboration Suite». Archivat des d'el original, el 4 d'agost de 2012. Consultat el 17 de novembre de 2015.
  14. ↑ DAViCal
  15. ↑ EVO Mail Server
  16. ↑ Kerio Connect
  17. ↑ Oracle Communications Calendar Server
  18. ↑ SOGo
  19. ↑ [2]
  20. ↑ Zimbra
  21. ↑ ownCloud

RFCs

  • RFC 2616 – HTTP
  • RFC 3744 – WebDAV Protocol de Control de l'Accés
  • RFC 4791 – CalDAV
  • RFC 4918 – WebDAV
  • RFC 5545 – iCalendar
  • RFC 5546 – iTIP